Afscheid nemen van PHP 7.1 en 7.2

In augustus gaan we afscheid nemen van PHP 7.1 en 7.2
Via deze weg willen we je graag op de hoogte brengen dat we later dit jaar oudere PHP versies gaan verwijderen op al onze hostingservers . Mocht je deze versies nog gebruiken, dan kan dit gevolgen hebben voor de werking van je website, dus lees deze pagina goed door. Ben je niet zo technisch? Dan bel 0628405197 voor uitleg.

Om welke PHP versies gaat het?
Momenteel kun je de volgende vier PHP versies gebruiken op onze servers: 7.1, 7.2, 7.3 en 7.4. Omdat PHP versies 7.1 en 7.2 aan het einde van dit jaar niet meer worden ondersteund en verouderd zijn, zullen binnenkort alleen PHP versies 7.3 en 7.4 nog beschikbaar zijn.

Waarom?
De PHP organisatie brengt regelmatig nieuwe PHP versies uit. In elke nieuwe versie zijn veiligheidslekken gedicht, nieuwe functies toegevoegd, en is de snelheid verbeterd. Zo is PHP versie 7.3 weer een stuk sneller dan 7.1! Eind dit jaar loopt de ondersteuning af voor PHP versies 7.1 en 7.2. Dit betekent dat vanaf dat moment veiligheidslekken niet meer worden gedicht. Om te voorkomen dat we gevaar lopen om te worden gehackt, is deze upgrade noodzakelijk. De nieuwe privacywetgeving verplicht ons dit ook.

Wanneer?
We voeren deze aanpassing in twee fases door:

Fase 1: begin augustus 2020
Alle hostingpakketten die momenteel PHP 7.1 of 7.2 gebruiken, zetten we om naar versie 7.3. Hierbij heb je in het control panel nog de mogelijkheid om de PHP versie tijdelijk terug te zetten naar 7.1 en 7.2. We controleren voor zover mogelijk alle websites op juiste werking, en zetten de PHP versie pro-actief terug – en informeren je hierover.

Fase 2: eind september 2020
Alle hostingpakketten die op dat moment nog PHP 7.1 of 7.2 gebruiken, zetten we nogmaals om naar versie 7.3. De mogelijkheid in het control panel om de PHP versie terug te zetten naar 7.1 en 7.2 is dan niet meer mogelijk. Ook wij kunnen deze versie dan niet meer voor je activeren.

De precieze planning met een datum per hostingserver zullen we later publiceren op onze website en op deze blog. Mocht de planning wijzigen, dan zullen we dat ook op deze pagina plaatsen.

Wat moet ik doen?
Indien je een CMS systeem zoals WordPress, Joomla, Drupal of PrestaShop gebruikt, zorg er voor dat je hebt geupdate naar een recente versie. De onderstaande versies zijn compatible met PHP 7.3:

WordPress 5.1 of hoger
Joomla 3.9.1 of hoger
Drupal 8.6.4 of hoger
PrestaShop 1.7.7 of hoger
Als je een ander systeem gebruikt, of indien je een website hebt laten maken door een website-bouwer – informeer dan bij die partij of je website geschikt is voor PHP 7.3.

Kan ik testen of mijn website geschikt is voor PHP 7.3?
Dat kan! Je kunt in het cPanel control panel van je hostingpakket via de optie “Select PHP version” de versie van je pakket nu al op 7.3 zetten. Mocht je site dan niet meer werken, dan kun je de versie direct weer terugzetten. Omdat verschillende PHP versies op een andere manier met de MySQL database praten, kan het nodig zijn dat je de database moet repairen/herstellen. Dit kan ook eenvoudig in het control panel.

Nog vragen?
Als je nog vragen hebt, dan zitten we voor je klaar. Je kunt ons mailen op design@petervanNunen.com of bellen op 0628405197.